Create Training Management Site error

Dec 11, 2009 at 8:33 AM

Hello,

 

I managed to get Contoso.TrainingManagement deployed to localhost sharepoint site and when I try to create the web site following the installation instruction I got the following error:

The template you have chosen is invalid or cannot be found.   at Microsoft.SharePoint.Library.SPRequestInternalClass.ApplyWebTemplate(String bstrUrl, String& bstrWebTemplate, Int32& plWebTemplateId)
   at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String& bstrWebTemplate, Int32& plWebTemplateId)

I have debugging turned on and customerrors to off. Is this a vseWSS related error?

 

Thanks.

 

Hong

 

 

 

Dec 11, 2009 at 1:03 PM

Hi Hong,

Issue could be with Template ID, I guess TrainingManagement Template ID conflicting with one of your existing templates.


<?xml version="1.0" encoding="utf-8"?>
<Templates>
  <Template Name="CONTOSOTRAINING" ID="99999">
    <Configuration ID="0" Title="Contoso Training Management Site" Description="Contoso Training Management Site" Hidden="FALSE" ImageUrl="/_layouts/images/stsprev.png" DisplayCategory="Contoso" />
  </Template>
</Templates>

currently Training Management is using 99999 and change to 99998 and redeploy solution.

 

Thanks

Appaji

Dec 12, 2009 at 1:13 AM

Thanks Appaji,

It solved the problem. I also have a deploy error with Contoso.PartnerPortal solution I believe is also related to configuration. It's posted here:

http://spg.codeplex.com/Thread/View.aspx?ThreadId=77909

 

Thanks.

 

Hong