Not able to install the solution

Jul 23, 2009 at 12:55 PM

When I am running the batch file ContosoSetup.bat , it is throwing error at the time of running the batch file 03b_PackageSolutions.bat.

The error that is logged in file VSeWSS1.3.log  located at C:\Documents and Settings\Administrator\Application Data\Microsoft\VSeWSS 1.3 .

The details are >

Error: System.NotImplementedException
System.NotImplementedException: The method or operation is not implemented.
at EnvDTE.Project.get_CodeModel()
   at Microsoft.SharePoint.Tools.Reflection.TypeFinder.GetTypesAsCodeElement(Project project, CodeElement parent, String targetTypeFullName)
   at Microsoft.SharePoint.Tools.Reflection.TypeFinder.Find(Project project, String targetTypeFullName)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureElementDirector.FindClasses(Project project)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureElementDirector.GetClassMap(Project project)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureElementDirector.Constract()
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureDirector.GetFeatureElement(ICollection`1 directors)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureDirector.Constract()
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceSolutionDirector.ConstractElements()
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceSolutionDirector.Constract()
   at Microsoft.SharePoint.Tools.SharePointSolutions.SolutionCreator.CreateCore(ISPProject project, IDirectorCreator creator)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SolutionCreator.Create(ISPProject project)
   at Microsoft.SharePoint.Tools.Forms.SPToolWindow.CreateSolutions()

 

Any help...

Aug 18, 2009 at 1:45 AM

Hi Rajeevdreamworld,

Can you make sure that VSeWSS service Application Pool ID  has Administrative privileges? Can you check log for Build solutions step(03a_BuildSolutions.bat). You can find ContosoInstall.txt under supportingfiles folder.

 

Thanks

Appaji

Jan 3, 2010 at 5:30 AM
Edited Jan 3, 2010 at 5:51 AM
svappaji77 wrote:

Hi Rajeevdreamworld,

Can you make sure that VSeWSS service Application Pool ID  has Administrative privileges? Can you check log for Build solutions step(03a_BuildSolutions.bat). You can find ContosoInstall.txt under supportingfiles folder.

 

Thanks

Appaji

I am having the same issue and I am running the VSeWSS using local machine  administrator account.

Still getting the above error.

 

Jan 4, 2010 at 12:35 PM

Hi ybbest,

Can you verify VSeWss 1.3 service is running(http://127.0.0.1:1378/SPService.svc) and AppPool id for VSeWss 1.3 service is member of Administrator's group.  if you change pool id then do iis reset to effect changes and try.

Thanks

Appaji